Note:
Please direct all future questions to Stackoverflow.com.
MAMP PRO customers can direct their questions to support.appsolute.de.
Hinweis:
Bitte posten Sie ab jetzt Ihre Fragen bei Stackoverflow.com.
Unseren Support für MAMP PRO erreichen Sie unter support.appsolute.de.

File to upload is too large file in phpmyadmin

You can ask general questions about MAMP here.

Moderator: severin

File to upload is too large file in phpmyadmin

Postby fmossiere » Fri Apr 12, 2013 8:33 am

Hi,

I use MAMP PRO and was trying to import a .sql file of 70Mb into PHPMYADMIN, but ran into this error message:

"You probably tried to upload too large file. Please refer to documentation for ways to workaround this limit."


I looked around and found information on changing values in php.ini, which I did, to no effect (increased the max_file_size, and timeout variables). Problem is that it looks like this is not being picked up. I am pretty sure I am changing the right file.

Configuration File (php.ini) Path /Applications/MAMP/conf/php5.2
Loaded Configuration File /Library/Application Support/appsolute/MAMP PRO/conf/php.ini

When I look at phpinfo(), I see that the loaded configuration file did not exist (conf/php.ini) ... I created the conf/ dir and added my modified php.ini in it. But I still see the wrong values in phpinfo (max_file_size is 30M although I changed to 120M).

Any idea how I can proceed?

Thanks in advance for your help.
fmossiere
 
Posts: 2
Joined: Fri Apr 12, 2013 8:26 am

Re: File to upload is too large file in phpmyadmin

Postby duanemitchell » Wed Apr 17, 2013 1:03 pm

I'm having the same problem with MAMP. Just updated from v2.0.5 where I did have it working. I can't find which files to change in the MAMP version.

Thank you.

Duane Mitchell
duanemitchell
 
Posts: 4
Joined: Wed Apr 17, 2013 1:33 am

Re: File to upload is too large file in phpmyadmin

Postby optiinfo » Wed May 15, 2013 6:47 am

Your best bet is to FTP it to the server and then ssh in (command line) and import the database that way. The resulting command will look something like:

mysql -hlocalhost -uUser -pPassword database_name < file_name
That way you can completely bypass any file upload or processing time restrictions.
optiinfo
 
Posts: 2
Joined: Wed May 15, 2013 6:23 am
Location: United States

Re: File to upload is too large file in phpmyadmin

Postby mori » Mon Jun 10, 2013 3:22 pm

I have the same problem but on my fresh retina macbook (OS X 10.8.4) with MAMP Pro 2.1.4 the "mysql" command is not found:

-bash: mysql: command not found

I enabled remote login and the root user.
What must I do to get the mysql command running with MAMP installed?
mori
 
Posts: 5
Joined: Tue Jul 19, 2011 11:26 am


Return to General questions

Who is online

Users browsing this forum: No registered users and 3 guests

wager-taxi