Bring Back PHP4 in 1.9+

Any wishes or suggestions for MAMP?
Post here what functions you are still missing for MAMP.

Moderator: severin

Post Reply
valendesigns
Posts: 1
Joined: Fri 29. Apr 2011, 13:08

Bring Back PHP4 in 1.9+

Post by valendesigns » Fri 29. Apr 2011, 13:12

I purchased MAMP Pro to show my support and updated recently (was hell by the way) and now PHP4 is not an option. I build plugins and themes for WordPress and must test them on PHP4, and now I'll have to keep switching back and forth between installs of MAMP. Not cool! Just because PHP4 is garbage doesn't mean you can just leave it out, a lot of people still use it. Please bring it back or I can guarantee I will not purchase MAMP Pro for the 2.0 branch.

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: Bring Back PHP4 in 1.9+

Post by Dirk Einecke » Mon 2. May 2011, 13:12

Hi,

if you need PHP 4 please use MAMP and MAMP PRO 1.8.4 (PHP 4.4.9 & 5.2.11).

Dirk
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

MailBeez
Posts: 1
Joined: Thu 26. May 2011, 11:53

Re: Bring Back PHP4 in 1.9+

Post by MailBeez » Thu 26. May 2011, 11:58

hi dirk,

I purchased the latest version of MAMP PRO and would like to test on PHP4 as well.

Is there a way to install 1.8.4 in parallel with 1.9.6?

cheers
cord

dotmh
Posts: 1
Joined: Wed 27. Jun 2012, 20:01

Re: Bring Back PHP4 in 1.9+

Post by dotmh » Wed 27. Jun 2012, 20:06

I agree , I am also a wordpress developer and really need to be able to test my plugins on PHP 4.x. One of the main reasons for using MAMP verse a standard stack install is that I could change the PHP version number. I have a MAMP 2.0 license code now , will that work in MAMP PRO 1.8 as recommend before?

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: Bring Back PHP4 in 1.9+

Post by Dirk Einecke » Mon 2. Jul 2012, 07:50

Hi,
dotmh wrote:I have a MAMP 2.0 license code now , will that work in MAMP PRO 1.8 as recommend before?
A MAMP PRO 2.x serial will not work with MAMP PRO 1.x.

Dirk
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

sage
Posts: 1
Joined: Tue 3. Jul 2012, 08:53

Re: Bring Back PHP4 in 1.9+

Post by sage » Tue 3. Jul 2012, 09:22

Dirk Einecke wrote:Hi,
dotmh wrote:I have a MAMP 2.0 license code now , will that work in MAMP PRO 1.8 as recommend before?
A MAMP PRO 2.x serial will not work with MAMP PRO 2.x.

Dirk

I think that should be:

A MAMP PRO 2.x serial will not work with MAMP PRO 1.x.

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: Bring Back PHP4 in 1.9+

Post by Dirk Einecke » Wed 4. Jul 2012, 07:01

@sage: Thank you. You're right. :-)
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

blue7floyd
Posts: 9
Joined: Tue 30. Oct 2012, 10:51

Re: Bring Back PHP4 in 1.9+

Post by blue7floyd » Thu 12. Sep 2013, 10:10

The best way is to download a cracked version form the torrentz. That might be the only way for it to work the way you want it to work. I don’t see any other way of helping you mate. Well, if I find one I’ll let you know for sure. asseenitontv.com

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest