MAMP and PHP 5.3

Any wishes or suggestions for MAMP?
Post here what functions you are still missing for MAMP.

Moderator: severin

sohdubom
Posts: 1
Joined: Sat 18. Jul 2009, 13:24

MAMP and PHP 5.3

Post by sohdubom » Sat 18. Jul 2009, 13:26

Does anyone knows when we will have a MAMP and PHP 5.3 package?

mmjaeger
Posts: 13
Joined: Wed 26. Mar 2008, 07:51

Re: MAMP and PHP 5.3

Post by mmjaeger » Wed 29. Jul 2009, 15:42

I'm interested in that one too

Holger Meyer
Posts: 148
Joined: Sun 2. Jan 2005, 10:55
Contact:

Re: MAMP and PHP 5.3

Post by Holger Meyer » Wed 5. Aug 2009, 22:05

We will include PHP 5.3 when all the third party libs which MAMP uses are PHP 5.3 compatible (eg eAccelerator, Xcache ..)
Holger Meyer
http://www.mamp.info
holger.meyer AT mamp.info

stevie
Posts: 1
Joined: Mon 10. Aug 2009, 15:32

Re: MAMP and PHP 5.3

Post by stevie » Mon 10. Aug 2009, 15:35

Hopefully it won't be long... I noticed that eaccelerator and xcache seem to be updated and compatible with 5.3 now...

alex3
Posts: 1
Joined: Wed 12. Aug 2009, 18:05

Re: MAMP and PHP 5.3

Post by alex3 » Wed 12. Aug 2009, 18:09

I'd really like to use PHP 5.3 with MAMP too, I've stumbled up a little bit trying to use finfo_ functions, the module isn't included until PHP 5.3 and installing it seems like a right pain judging by the lengthy, terminal-heavy blog posts about it!

Handyman
Posts: 21
Joined: Tue 20. Jun 2006, 07:20
Contact:

Re: MAMP and PHP 5.3

Post by Handyman » Fri 4. Sep 2009, 20:04

It would be really awesome if instead of PHP 4 and PHP 5.2 built into MAMP that we could have PHP 5.2.x and PHP 5.3.x
PHP4 is EOL, so it would be nice to move on to the latest and greatest so we can keep up with development.

Snow Leopard comes packaged with PHP 5.3.0 now as well as Apache 2.2.

Also, I wonder if it's possible to have a chose on MySQL as well - MySQL 5.4.x and MySQL 5.1.x.
I'm not sure how much MySQL 5.4 will break as of yet, I haven't had a chance to work with it.
http://startrekguide.com Testing, support and mods for phpBB3 and future home of StarTrekGuide

ironnova
Posts: 2
Joined: Wed 28. Oct 2009, 15:41

Re: MAMP and PHP 5.3

Post by ironnova » Wed 28. Oct 2009, 15:49

I'd really like to use PHP 5.3 with MAMP. I use MAMP as test environment for developing web apps. PHP4 is useless for me but 5.2 and 5.3 are much important.

radikalfree
Posts: 3
Joined: Mon 5. Oct 2009, 02:01

Re: MAMP and PHP 5.3

Post by radikalfree » Mon 9. Nov 2009, 15:25

Pareil pour moi, ça fait maintenant plusieurs mois que php 5.3 est sorti...

Beaucoup de projet passe en php 5.3 et cela devient une version incontournable, j'aime bien MAMP mais je vais devoir passer à autre chose à cause de ce manque...

Dommage

althea06
Posts: 1
Joined: Fri 13. Nov 2009, 07:41

Re: MAMP and PHP 5.3

Post by althea06 » Fri 13. Nov 2009, 07:49

I used to hear this but now, I am testing how this thing really works. MAMP will always be more awesome when we use PHP 5.2.x or PHP 5.3.x with it. Never been tested this one, but hear good feedbacks from others.

sit1way
Posts: 2
Joined: Tue 8. Dec 2009, 11:50

Re: MAMP and PHP 5.3

Post by sit1way » Tue 8. Dec 2009, 11:59

Agreed, PHP 5.3 has been stable for some time now.

Seeing as PHP 5.3 has some highly useful new features like namespaces, late static binding and full datetime support, it would be great if the MAMP team would get PHP 5.3 in place for developers that use PHP 5.3 in production (e.g. on Linux) and would love to use PHP 5.3 in their MAMP test environment.

MAMP has been a great development tool, but starting to get out-of-date at this point barring getting PHP 5.3 in place.

The masses are calling, is anyone listening?

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: MAMP and PHP 5.3

Post by Dirk Einecke » Tue 8. Dec 2009, 16:25

Hi,
sit1way wrote:The masses are calling, is anyone listening?
Yes, the MAMP team is listening!
We will discuss this again in the developer/manager teams.

Thanks for the feedback.

greetings
Dirk Einecke
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

mmjaeger
Posts: 13
Joined: Wed 26. Mar 2008, 07:51

Re: MAMP and PHP 5.3

Post by mmjaeger » Tue 8. Dec 2009, 16:30

sit1way wrote:Agreed, PHP 5.3 has been stable for some time now.

Seeing as PHP 5.3 has some highly useful new features like namespaces, late static binding and full datetime support, it would be great if the MAMP team would get PHP 5.3 in place for developers that use PHP 5.3 in production (e.g. on Linux) and would love to use PHP 5.3 in their MAMP test environment.

MAMP has been a great development tool, but starting to get out-of-date at this point barring getting PHP 5.3 in place.

The masses are calling, is anyone listening?
as to my knowledge, Zend Optimizer doesn't support yet PHP 5.3, does it? The ExpressionEngine Trial version for instance requires ZO to be installed so that would be a problem - looks like we need another choice like PHP 4, PHP 5.2... and PHP 5.3 maybe?

sit1way
Posts: 2
Joined: Tue 8. Dec 2009, 11:50

Re: MAMP and PHP 5.3

Post by sit1way » Tue 8. Dec 2009, 17:09

I should point out that MAMP is an excellent product as is -- while setting up php5.3 with any flavor of MySQL5 on Linux is a relatively easy task, on OSX attempting the same is a somewhat nightmarish experience based on my tries to-date, just horrible, always some dependency missing and difficult to overcome/find the missing lib.

So, MAMP has been very helpful to yours truly.

When php5.3 gets built-in, I will be over the moon ;--)

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: MAMP and PHP 5.3

Post by Dirk Einecke » Wed 9. Dec 2009, 12:03

Hi,
as to my knowledge, Zend Optimizer doesn't support yet PHP 5.3, does it? The ExpressionEngine Trial version for instance requires ZO to be installed so that would be a problem
For your information .... the current ExpressionEngine 2.0 beta trial works with MAMP / MAMP PRO without problems. There was a problem with the first version of ExpressionEngine 2.0 beta. But this was solved by the ExpressionEngine team.

greetings
Dirk Einecke
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

TheLimey
Posts: 1
Joined: Wed 9. Dec 2009, 17:50

Re: MAMP and PHP 5.3

Post by TheLimey » Wed 9. Dec 2009, 17:55

I think this was suggested in another thread, but it would be much better to have a switch to change between PHP 5.2.x and 5.3.x (as well as the PHP 4). Personally, I need to test my code on both 5.2.x and 5.3.x versions.

WAMP has a great system where you can choose which version of Apache/MySQL/PHP you run. If MAMP Pro had that, then it would be fantastic :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest