PHP 5.3.3

Any wishes or suggestions for MAMP?
Post here what functions you are still missing for MAMP.

Moderator: severin

azes
Posts: 6
Joined: Sun 24. Jan 2010, 06:09

Re: PHP 5.3.3

Post by azes » Wed 2. Mar 2011, 05:13

Need php 5.3.3 at least to consider upgrade to 5.3.5.

Do you think you waste your time by upgrading php version because it's not necessary ? seriously ? Mostly developer work on MAMP and thy mainly need the last version in production for lot of reason :

- Need of new feature.
- Need to test their application on the new version.
- Dependencies require early version.
- etc...

Actually my project won't work on php 5.3.2 and work perfectly on php 5.3.X (X>2) for some reason like old php class constructor style still be active in php 5.3.2 for example.

sora
Posts: 1
Joined: Mon 21. Mar 2011, 14:51

Re: PHP 5.3.3

Post by sora » Mon 21. Mar 2011, 14:56

Hello,

I would like to have the module INTL for my website. It's an essential extention for making my website working.

I am waiting for this feature.

jonadesign
Posts: 2
Joined: Sat 16. Apr 2011, 23:19

Re: PHP 5.3.3

Post by jonadesign » Sat 16. Apr 2011, 23:36

Hi,
I just purchased Mamp Pro in order to start developping a Symfony2 project, I found myself very disapointed seeing that php5.3.5 was included but not the and especially the intl extension.. searching for solutions i found this post and i start wondering why there is not any answer from the mamp staff since more than 6 months about this topic wich in my humble opinion is quite important for a lot of developpers.

So if anyone from MAMP staff could answer this what they are planning to do, it would be really appreciated

cheers

[edit]
Ok I Apologize, I just said a bunch of nonsense since php5.3.5 is actually the current version included in mamp ><
I was just upset since the intl extension required for symfony2 is not included, and i did buy mamp pro in order to start developing a symfony2 project, after a long night trying to compile everithing on my own, wich was quite difficult especially with mysql.

So i apologize again to the developpers and just ask if the intl extension is planned to be included in further version of mamp ?
beside of that i have to say that mamp is really powerfull and easy to use
thank you

cheers
[/edit]

bradcamry
Posts: 1
Joined: Mon 16. May 2011, 09:23

Re: PHP 5.3.3

Post by bradcamry » Mon 16. May 2011, 09:28

The PHP development team would like to announce the immediate availability of PHP 5.3.3. It is however something to be aware of. Since Namespaces were not a part of the 5.2 version of PHP, this change has no affect on developers still using 5.2.x either.

cjpa
Posts: 1
Joined: Thu 25. Aug 2011, 21:06

Re: PHP 5.3.3

Post by cjpa » Thu 25. Aug 2011, 21:08

If you need the intl-extension, check the following blog-post:
http://blog.geertvd.be/2011/05/18/insta ... on-on-mamp

jonadesign
Posts: 2
Joined: Sat 16. Apr 2011, 23:19

Re: PHP 5.3.3

Post by jonadesign » Wed 14. Sep 2011, 23:42

cjpa wrote:If you need the intl-extension, check the following blog-post:
http://blog.geertvd.be/2011/05/18/insta ... on-on-mamp
Great, works perfectly, thanks for the tips cjpa :)

User avatar
jfgrissom
Posts: 2
Joined: Sun 20. Jun 2010, 17:36

Re: PHP 5.3.3

Post by jfgrissom » Sun 11. Dec 2011, 00:39

cjpa wrote:If you need the intl-extension, check the following blog-post:
http://blog.geertvd.be/2011/05/18/insta ... on-on-mamp
Hi,

Yes, it worked perfectly, and it only took about 30 minutes to get it all done.

Very nice! (Much better than installing Zend and fiddling with that.)

Thanks for the post!

Jay
The Principle Of Antagonism:
A protagonist and his story can only be as intellectually fascinating and emotionally compelling as the forces of antagonism make him.
---Robert McKee
http://jfgrissom.wordpress.com

ntanim
Posts: 1
Joined: Sun 11. Mar 2012, 19:11

Re: PHP 5.3.3

Post by ntanim » Sun 11. Mar 2012, 19:16

I think it would be very beneficiary to upgrade MAMP PHP to 5.3.3 or even 5.3.4 (current) since this version include the internationalization extension which is a big upgrade.

If you are not planning on upgrading, maybe you can give a quick instructions on how to install this extension with the current 5.3.2.

Thanks.
Hi, This is Tanim. Nice to meet you.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest