Falscher Apache User

Hier können Sie von gefundenen Bugs berichten. Wir sind für jeden Hinweis dankbar.

Moderators: severin, Dirk Einecke

Post Reply
danielkoch
Posts: 12
Joined: Sun 29. Jul 2007, 09:17

Falscher Apache User

Post by danielkoch » Wed 5. Nov 2008, 07:34

Hallo zusammen,

ich habe unter MAMP Pro 1.7.2 neuerdings extreme Probleme mit Dateizugriffsrechten. Neben den Standardzugriffsproblemen, die sich jedoch meist mit chmod -R 755 etc. beheben lassen hängt es m.E. an falschen Eigentümern-/Gruppenzuordnungen. So bin ich mal auf die Suche gegangen:
In MAMP selber steht unter "Server --> Allgemein" Apache bzw. MySQL user: www/mysql (das war bei mir auch immer schon so). Führe ich jedoch ein ps auxw | grep httpd aus zeigt er an, dass der Prozess unter meinem Systemuser läuft.Ändere ich nun in MAMP die User auf "Benutzername/Benuztername" habe ich keine Zugriffsprobleme mehr; laut Hinweis birgt diese Einstellung jedoch Sicherheitsprobleme. Deshalb würde ich gerne wieder zu der alten Einstellung zurück gehen.

Danke und Grüße
Daniel

danielkoch
Posts: 12
Joined: Sun 29. Jul 2007, 09:17

Re: Falscher Apache User

Post by danielkoch » Sun 15. Mar 2009, 07:26

Bevor mir noch jemand antwortet, antworte ich lieber selber :lol:

Es lag an der Tatsache, dass die Webroots auf einem Truecrypt-Volumen lagen und dort eingestellt war, dass die Eigentümerrechte ignoriert werden sollen. Dies lässt sich beheben: Über Apfel + I den "Information"-Dialog im Finder aufrufen und dort dann den Haken bei "Eigentümer auf diesem Volume ignorieren" entfernen.

Grüße
Daniel

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest