MAMP startet unter Snow Leopard nicht mehr

Hier können Sie von gefundenen Bugs berichten. Wir sind für jeden Hinweis dankbar.

Moderators: severin, Dirk Einecke

Post Reply
matzegi
Posts: 5
Joined: Sun 13. Sep 2009, 07:36

MAMP startet unter Snow Leopard nicht mehr

Post by matzegi » Sun 13. Sep 2009, 07:44

Hallo,

ich bin ein echter Fan von MAMP. Leider funktioniert die Anwendung gar nicht mehr, seitdem ich ein neues Macbook Pro 15" 2,66 Ghz geholt habe, auf dem Snow Leopard schon installiert war. Wenn ich MAMP starte, bleibt Server und MySQL offline (rot). Auch ein Klick auf "Server starten" hat das gleiche als Resultat: Der Server bleibt offline. Es erscheint nur kurz der drehende Kreis und der Server bleibt aus.

Ich hab die neuste Version von MAMP 1.8.1 runtergeladen, in Applications kopiert. Es werden noch nicht mal Logs angelegt. Ich weiß auch nicht mehr weiter. Ich scheine ja auch der einzige zu sein, dem das passiert ;) Könnt ihr mir helfen?

Viele Grüße
Matze

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: MAMP startet unter Snow Leopard nicht mehr

Post by Dirk Einecke » Sun 13. Sep 2009, 20:19

Hi,

MAMP 1.8.1 ist nicht die neuste Version.
Bitte laden Sie sich MAMP 1.8.2 herunter und versuchen es erneut. -> Download-Seite

MfG
Dirk Einecke
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

matzegi
Posts: 5
Joined: Sun 13. Sep 2009, 07:36

Re: MAMP startet unter Snow Leopard nicht mehr

Post by matzegi » Tue 15. Sep 2009, 10:05

Hi Dirk,

also ich hab mir die neueste Version (1.8.2) runtergeladen, aber immer noch verweigert MAMP den Dienst, es gibt keine Logfiles und der Server startet leider nicht und leider auch ohne jedwede Fehlermeldung. Auf meinem Mac Pro und meinem alten MacBook Pro läuft alles super, aber auf dem neuen MacBook Pro (eine Woche alt) mit vor installiertem Snow Leopard läuft leider gar nichts :( Ich weiß nicht mehr weiter.

Viele Grüße
Matze

severin
Posts: 225
Joined: Thu 8. Mar 2007, 08:03
Location: Germany

Re: MAMP startet unter Snow Leopard nicht mehr

Post by severin » Tue 15. Sep 2009, 11:15

Hi Matze,

kannst Du auch in den allgemeinen Logs (in der Applikation Konsole) nachschauen? Welchen Port sollte Apache benutzen? 8888 oder 80?

Gruß,

Severin

gaz
Posts: 1
Joined: Sat 19. Sep 2009, 10:30

Re: MAMP startet unter Snow Leopard nicht mehr

Post by gaz » Sat 19. Sep 2009, 10:39

Hallo,

ich arbeite auf meinem Macbook-Pro nicht als Administrator (mit eingeschränkten Benutzerrechten) und bei mir tauchte exakt das gleiche Problem auf wie oben beschrieben.

In der Konsole standen einige Meldungen mit "Permission denied". Ich konnte das Problem lösen, indem ich meinem Nutzer Lese- und Schreibrechte für den MAMP-Ordner im Programmverzeichnis gegeben habe.

Unter Leopard und MAMP-Version 1.72 funktionierte das trotz eingeschränkter Rechte wunderbar.

Wird das in zukünftigen Versionen wieder funktionieren? Oder wie kann ich MAMP richtig installieren, ohne die Rechte im Programmverzeichnis ändern zu müssen (ich arbeite schließlich mit eingeschränkten Rechten, damit da nicht jeder schreiben darf...)?

Bin für jede Hinweise dankbar :-)

Gruß, Gaz.

matzegi
Posts: 5
Joined: Sun 13. Sep 2009, 07:36

Re: MAMP startet unter Snow Leopard nicht mehr

Post by matzegi » Mon 21. Sep 2009, 08:31

Hallo Zusammen,

also der Apache kann unter 80, oder 8888 oder 8080 laufen. Das wäre mir auf lokaler Ebene egal. Es funktioniert allerdings mit gar keiner Port Einstellung. Das Problem ist ja auch nicht, dass ich nicht auf den Server komme, sondern das er gar nicht erst gestartet werden kann.

Ich habe nun versucht, wie von Gaz beschrieben, die Benutzerrechte für meinen User für den MAMP Order auf "lesen und schreiben" zu setzen, aber auch danach funktioniert es nicht. Zumal ich auch MAMP so einstelle, das das htdocs Verzeichnis in meinem Websites Ordner von OSX liegt. Es erscheint jedoch immer nur kurz das spinning wheel in der MAMP Programmoberfläche und nach 5 Sekunden werden wieder die roten Lampen angezeigt,das Server und Datenbank nicht online sind. Es gibt auch keine Fehlermeldung, wie "der Server konnte nicht gestartet werden". Zudem werden keine Protokolle und LOGS in das MAMP Verzeichnis geschrieben. Sehr seltsam :S

Hat denn noch irgendwer irgendwelche Vorschläge?

Ein verzweifelter Matze :)

matzegi
Posts: 5
Joined: Sun 13. Sep 2009, 07:36

Re: MAMP startet unter Snow Leopard nicht mehr

Post by matzegi » Mon 21. Sep 2009, 08:39

Ich hab nun auch mal in der Konsole von OSX nachgesehen und folgende Meldungen erhalten:

21.09.09 10:23:00 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:00 mysqld_safe Logging to '/Applications/MAMP/logs/mysql_error_log.err'.
21.09.09 10:23:01 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:01 mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql
21.09.09 10:23:01 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 100: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:01 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 137: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:01 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:01 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended
21.09.09 10:23:01 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 100: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:02 [0x0-0x54054].de.appsolute.MAMP[539] (13)Permission denied: httpd: could not open error log file /Applications/MAMP/logs/apache_error_log.
21.09.09 10:23:02 [0x0-0x54054].de.appsolute.MAMP[539] Unable to open logs
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:04 mysqld_safe Logging to '/Applications/MAMP/logs/mysql_error_log.err'.
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:04 mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 100: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 137: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:04 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 100: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] (13)Permission denied: httpd: could not open error log file /Applications/MAMP/logs/apache_error_log.
21.09.09 10:23:04 [0x0-0x54054].de.appsolute.MAMP[539] Unable to open logs
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:05 mysqld_safe Logging to '/Applications/MAMP/logs/mysql_error_log.err'.
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:05 mysqld_safe Starting mysqld daemon with databases from /Applications/MAMP/db/mysql
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 100: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 137: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] 090921 10:23:05 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] /Applications/MAMP/Library/bin/mysqld_safe: line 100: /Applications/MAMP/logs/mysql_error_log.err: Permission denied
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] (13)Permission denied: httpd: could not open error log file /Applications/MAMP/logs/apache_error_log.
21.09.09 10:23:05 [0x0-0x54054].de.appsolute.MAMP[539] Unable to open logs

Vielleicht hilft das ja weiter :S

Viele Grüße
Matze

matzegi
Posts: 5
Joined: Sun 13. Sep 2009, 07:36

Re: MAMP startet unter Snow Leopard nicht mehr

Post by matzegi » Mon 21. Sep 2009, 08:42

So ich habs geschafft. Die Benutzerrechte müssen nicht nur für den MAMP Ordner, sondern alle darin enthaltenen Dateien geändert werden. Dann funktionierts auch bei mir :)

Also vielen Dank CAZ :)

Matze

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest