MAMP 1.8.3 Apache startet nicht

Hier können Sie von gefundenen Bugs berichten. Wir sind für jeden Hinweis dankbar.

Moderators: severin, Dirk Einecke

Post Reply
endymion
Posts: 6
Joined: Thu 12. Jul 2007, 15:57

MAMP 1.8.3 Apache startet nicht

Post by endymion » Mon 7. Dec 2009, 13:11

Was bisher geschah:
Ich habe einen neuen Rechner in Betrieb genommen (macmini unter 10.6.2 Snowleopard) und per Migrationsassistent die Daten vom alten Rechner übertragen.
Dort hatte ich noch die Version MAMP 1.8.2 installiert.

Als ich MAMP gestartet habe, liess sich der sql-Server starten, aber Apache tat keinen Mucks.

Ich habe dann nach Bens Anleitung MAMP 1.8.3 installiert.
Tja, keine Besserung. Apache startet nicht.

Als Fehlermeldung lese ich in der Konsole:
07.12.09 13:25:36 [0x0-0x1e01e].de.appsolute.MAMP[892] Syntax error on line 326 of /Applications/MAMP/conf/apache/httpd.conf:

In der Zeile steht:
User [mein Benutzername]
Group #-1
</IfModule>
</IfModule>

Ich weiß zu wenig über MAMP Bescheid, um daraus eine Idee zu bekommen, was ich tun kann.
Wo könnte der Fehler liegen?

Bin dankbar für jeden Hinweis.

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: MAMP 1.8.3 Apache startet nicht

Post by Dirk Einecke » Tue 8. Dec 2009, 09:06

Hi,

ist der Wert für [mein Benutzername] ein Wort?
Oder ist es sowas wie "mac mini"?

Wir hatten bereits MAMP User mit solchen Benutzernamen aus mehrere Wörtern obwohl das Mac OS X eigentlich beim Anlegen eines Benutzers garnicht zulässt.

Dirk
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

endymion
Posts: 6
Joined: Thu 12. Jul 2007, 15:57

Re: MAMP 1.8.3 Apache startet nicht

Post by endymion » Tue 8. Dec 2009, 13:02

Danke schön!

Es ist einfach mein Name, also Vor- und Nachname.
So wie mein mac meint, dass ich heisse.

Aber damit hat es schon was auf sich, in der "alten" config-Datei (auf dem Vorgängerrechner) stand da nur mein Vorname.
Ich hab schon probiert, meinen Nutzernamen auf dem Mac von Vor- und Nachname auf nur Vorname zu ändern. Das mag er aber nicht.
Aber vielleicht kann man den Namen auch lokal auf den Apache bezogen ändern/einrichten?

(Ich hab übrigens in meiner Not ein Demo von MAMP PRO angeschmissen.
Damit gehts.)

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: MAMP 1.8.3 Apache startet nicht

Post by Dirk Einecke » Tue 8. Dec 2009, 16:23

Hi,

können Sie mal bitte in den Systemeinstellungen von Mac OS X das Benutzer-Panel öffnen, die Einstellungen entsichern (Schloss im unteren Teil des Panels muss offen sein) und dann auf den verwendeten Benutzer in der linken Liste einen Rechtsklick machen und "Erweiterte Optionen..." auswählen und schauen, was bei Accountname steht?

Dirk
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

endymion
Posts: 6
Joined: Thu 12. Jul 2007, 15:57

Re: MAMP 1.8.3 Apache startet nicht

Post by endymion » Tue 8. Dec 2009, 18:09

Okay....
Da stehen auch Vor- und Nachname.

Dirk Einecke
Site Admin
Posts: 278
Joined: Thu 4. Nov 2004, 11:11
Location: Karlsruhe (Germany)
Contact:

Re: MAMP 1.8.3 Apache startet nicht

Post by Dirk Einecke » Wed 9. Dec 2009, 11:53

Hi,
endymion wrote:Da stehen auch Vor- und Nachname.
Da liegt also das Problem. Weil der Accountname, der hier in der httpd.conf verwendet wird, darf keine Leerzeichen enthalten [1]. Ist dies aber der Fall, gibt es den Syntax-Error. Ich vermute, dass dieser Fehler durch den Migrationsassistenten verursacht wurde (also ein Bug von Mac OS X).

Man kann über die Systemeinstellungen zwar den Accountnamen ändern, aber da steht im entsprechenden Dialog nicht umsonst Achtung mit drin. Ich werde das mal mit einem Test-Account auf meinem Mac ausprobieren. Ein Entwickler hat auch schon eine andere Idee, wie man einen falschen Accountnamen eventuell umgehen kann ... muss ich aber auch erst ausprobieren.

[1] Das kann man recht einfach selber ausprobieren indem man mal einen neuen Benutzer anlegt und versucht, ein Leerzeichen dem Accountnamen hinzuzufügen.

Dirk
Best Regards / Mit freundlichen Grüßen
Dirk Einecke (MAMP & MAMP PRO Team)

NEW: MAMP & MAMP PRO 3 released | MAMP & MAMP PRO 3 veröffentlicht

All about MAMP & MAMP PRO: Website | Bugbase | Blog (german) | Blog (english) | Online documentation (Wiki)

endymion
Posts: 6
Joined: Thu 12. Jul 2007, 15:57

Re: MAMP 1.8.3 Apache startet nicht

Post by endymion » Wed 23. Dec 2009, 10:48

So, nun bin ich einen Schritt weiter.
Ich habe den Kurznamen om Mac OS geändert (brav Backup gemacht, es sieht aber bisher unauffällig aus) und in der httpd.conf steht jetzt auch der richtige Kurzname, ohne Leerzeichen diesmal.
Das einzig Blöde ist: Apache startet immer noch nicht. Nur SQL.

Any further ideas?

EDIT
Fehlermeldung diesmal:
Syntax-Error in dieser Zeile:
Include/Applications/MAMP/conf/apache/vhosts/*.conf

EDIT2
Ich alter Hacker, ich...
Ich hab in der httpd.conf der Vorgängerversion nachgeguckt, dort gab es die zickende Zeile noch nicht.
Ich hab sie dann in der aktuellen Version auskommentiert.
Tja, nu gehts.
;)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest