Mysql wil not start with MAMP PRO but works fine in MAMP

Report any found bug here. We are grateful for any useful clues.

Moderator: severin

Post Reply
Posts: 1
Joined: Fri 11. Apr 2014, 15:04

Mysql wil not start with MAMP PRO but works fine in MAMP

Post by pepijngracious » Fri 11. Apr 2014, 15:10

I can start Apache & Mysql just fine using MAMP, but when trying to start Mysql through MAMP PRO the following error log is spat out:

Code: Select all

140411 17:01:08 mysqld_safe Starting mysqld daemon with databases from /Library/Application Support/appsolute/MAMP PRO/db/mysql
140411 17:01:09 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
140411 17:01:09 [Warning] Setting lower_case_table_names=2 because file system for /Library/Application Support/appsolute/MAMP PRO/db/mysql/ is case insensitive
140411 17:01:09 [Note] Plugin 'FEDERATED' is disabled.
/Applications/MAMP/Library/bin/mysqld: Table 'mysql.plugin' doesn't exist
140411 17:01:09 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
140411 17:01:09 InnoDB: The InnoDB memory heap is disabled
140411 17:01:09 InnoDB: Mutexes and rw_locks use GCC atomic builtins
140411 17:01:09 InnoDB: Compressed tables use zlib 1.2.3
140411 17:01:09 InnoDB: Initializing buffer pool, size = 128.0M
140411 17:01:09 InnoDB: Completed initialization of buffer pool
140411 17:01:09 InnoDB: highest supported file format is Barracuda.
InnoDB: Error: trying to access page number 24110 in space 0,
InnoDB: space name ./ibdata1,
InnoDB: which is outside the tablespace bounds.
InnoDB: Byte offset 0, len 16384, i/o type 10.
InnoDB: If you get this error at mysqld startup, please check that
InnoDB: your my.cnf matches the ibdata files that you have in the
InnoDB: MySQL server.
140411 17:01:10  InnoDB: Assertion failure in thread 140735165240080 in file fil0fil.c line 4578
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: about forcing recovery.
15:01:10 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 134084 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x40000
0   mysqld                              0x000000010028081c my_print_stacktrace + 44
1   mysqld                              0x0000000100021624 handle_fatal_signal + 692
2   libsystem_platform.dylib            0x00007fff8c4625aa _sigtramp + 26
3   ???                                 0x0000000000000000 0x0 + 0
4   libsystem_c.dylib                   0x00007fff8d2fcb1a abort + 125
5   mysqld                              0x00000001002cf1e3 fil_io + 1059
6   mysqld                              0x00000001002b97af buf_read_page_low + 383
7   mysqld                              0x00000001002b9fa5 buf_read_page + 85
8   mysqld                              0x00000001002b4431 buf_page_get_gen + 673
9   mysqld                              0x000000010034fdd5 trx_undo_lists_init + 373
10  mysqld                              0x0000000100348e2e trx_rseg_mem_create + 334
11  mysqld                              0x0000000100348fed trx_rseg_list_and_array_init + 157
12  mysqld                              0x000000010034a147 trx_sys_init_at_db_start + 215
13  mysqld                              0x000000010033eafd innobase_start_or_create_for_mysql + 5805
14  mysqld                              0x00000001003114c1 _ZL13innobase_initPv + 1473
15  mysqld                              0x0000000100027028 _Z24ha_initialize_handlertonP13st_plugin_int + 104
16  mysqld                              0x000000010017f0f1 _ZL17plugin_initializeP13st_plugin_int + 97
17  mysqld                              0x0000000100181810 _Z11plugin_initPiPPci + 3776
18  mysqld                              0x00000001000ccce5 _Z11mysqld_mainiPPc + 10405
19  mysqld                              0x0000000100001804 start + 52
The manual page at contains
information that should help you find out what is causing the crash.
140411 17:01:10 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/ ended
The usual "kill mysql and restart mamp" is of no use in this case since no mysql service is actually running.
There is no /etc/my.cnf
Completely remove MAMP & MAMP PRO and the problem still exists, even checked to see that the /Application/MAMP dirs were gone
Repaired permissions using diskutil, still no go
Started mysql in safe mode and ran mysql_upgrade
Tried innodb_force_recovery

I'm at a loss by now, I hope someone can help me with this problem.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests