Forbidden starting page

Report any found bug here. We are grateful for any useful clues.

Moderator: severin

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Forbidden starting page

Post by charlesclayton » Wed 3. Sep 2008, 19:56

This is a simple complication that I am running into, and am not familiar with the means of adjusting in order for everything to run properly.

Basically, this is what I run into:

1. I install the latest MAMP.

2. Drag my files into the "htdocs" folder.

3. Open the MAMP application, both lights turn green but I instead of the standard local MAMP page I get the following-

"Forbidden - You don't have permission to access /MAMP/ on this server."
Picture 2.png
Forbidden
Picture 2.png (82.33 KiB) Viewed 54824 times
Of course, this may not be a bug but more likely a permission/setting is incorrect.. Either way, I could find no information related to addressing this problem which I found odd considering it would seem that a simple permissions setting would be covered somewhere... In the case that it is a simple settings problem, I feel this simple issue should be more easily available on a help page (or something similar), instead of the answer being left to this forum for others to discover.

I appreciate any advice, or suggestions. Thank you & Namaste

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Wed 3. Sep 2008, 23:36

Go into the Finder and go to the Applications folder and right-click on the MAMP folder and choose Get Info. It is probably locked for changing ownership but that is ok. Click Details to show them. It should show

Owner is you: Read Write
Group is admin: Read Write
Others: Read Only (or Read Write).

Then click Apply To Enclosed Items

Close the Get Info window.

Try MAMP again and see if it works now.

Al
www.insurancesolutions123.com

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Re: Forbidden starting page

Post by charlesclayton » Thu 4. Sep 2008, 17:42

Ok, so I opened the MAMP folder, the setting were already:

Owner is you: Read Write
Group is admin: Read Write
Others: Read Only

The setting were locked as you mentioned, but I unlocked and changed just to make sure.

I then applied to all enclosed items, but unfortunately when I run MAMP I get the same "Forbidden" starting screen.

Thank you for the help, I sincerely appreciate it... But I didn't notice any changes unfortunately.
http://www.Mudutu.com
Knowledge is Power - Share it

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Thu 4. Sep 2008, 18:52

Click Preferences and look in all the tabs to see if anything looks strange. Then click OK. Apache and SQL will reload.

For the hell of it try this: http://localhost:8888/MAMP/frame.php?src=info.php

Do you get the same error?

Al

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Re: Forbidden starting page

Post by charlesclayton » Thu 4. Sep 2008, 19:48

All MAMP preferences were default,

I launch the start page, and get the same "Forbidden" message

I tried "http://localhost:8888/MAMP/frame.php?src=info.php" with the same results...

Also I decided to empty my cache incase that had any interference with permissions. But I am still receiving the same error.

I wonder what could be causing this, I used MAMP about 6 months ago and I never had a problem. Because I hadn't used it in a while, and none of my original material is needed for this new project, I decided to delete the MAMP folder entirely and reinstall with a fresh version of MAMP. I didn't think of a reinstall being an problem, but to best address this issue I thought I'd let everyone know my past history with MAMP.

Thanks Al, I really appreciate you taking the time to help me.
http://www.Mudutu.com
Knowledge is Power - Share it

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Fri 5. Sep 2008, 16:25

Did it work after the re-install?

Al

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Re: Forbidden starting page

Post by charlesclayton » Fri 5. Sep 2008, 16:59

Actually, No...

I encountered the error for my first time after I installed the newest version and attempted to open the MAMP start page (opens automatically when you run the MAMP application)

That is why I am confused, because I don't understand why a previous version with no problems would effects the permissions, of a newer version..
http://www.Mudutu.com
Knowledge is Power - Share it

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Sat 6. Sep 2008, 04:23

This IS very strange.

Code: Select all

    <?php
    echo phpinfo();
    ?>
For the hell of it create a text file with TextWrangler (get it if you don't have it... free) and call it test1.php and put it in MAMP/htdocs folder.

Then start up MAMP and enter http://localhost:8888/test1.php

If you get an error, start up Activity Monitor and see if you find any httpd processes going.

Let me know what happens

Al

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Making Progress!

Post by charlesclayton » Sat 6. Sep 2008, 18:55

Ok we are making some progress : )

Installed TextWrangler,

Created the "test1.php" file and placed in MAMP/htdocs folder

Opened the MAMP Application, Starting screen leads to "Forbidden" page.

Entered the URL "http://localhost:8888/test1.php" and a completely blank screen is returned... Instead of Forbidden!

Here is a picture:
Picture 1.png
Picture 1.png (82.65 KiB) Viewed 54750 times
Exciting to see that we are making progress, Thanks so much Al, you continue to be of great help.
http://www.Mudutu.com
Knowledge is Power - Share it

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Sat 6. Sep 2008, 21:32

The white screen means that PHP bombed out for some reason. (MAMP is pre set with "display errors off" for some reason.

For the hell of it change the test1.php code as below. (Note I took out the "echo" before phpinfo()
(don't forget the ending semi-colons). Just select and paste.

Code: Select all

<?php
echo "this is the start";
phpinfo();
echo "<br>this is the end";
?>

Run it and see if it at least prints the beginning message.

What is in the php error log. Go to Applications, MAMP, logs and click php.error.log. It should open in Console or maybe TextEdit. You might right-click it and choose TextWrangler.

Scroll down to see what the last few errors are and let us know.

Al

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Re: Forbidden starting page

Post by charlesclayton » Sat 6. Sep 2008, 23:39

Both beginning and ending messages were displayed along with the list of PHP info.. :D

I checked the php_error.log and this was the only record:

[06-Sep-2008 11:44:32] PHP Parse error: syntax error, unexpected T_STRING in /Applications/MAMP/htdocs/test1.php on line 2
http://www.Mudutu.com
Knowledge is Power - Share it

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Sun 7. Sep 2008, 01:13

OK, so you got both the beginning and ending message and the long screen of PHP gibberish. Good.

Shut down MAMP.

Open up the php error log again with TextWrangler and delete everything in there and save it and close it.

Start up MAMP and then go and re-open the php error log in TextWrangler window and see if any error showed up. If not then perhaps we have a SQL error. Go and open the mysql error log and see if there is anything in there. My guess that is where the problem must be when starting it up.

My advice would be to just reinstall the whole thing and make sure you can start up MAMP without the problem before you put anything in htdocs.

Al

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Re: Forbidden starting page

Post by charlesclayton » Sun 7. Sep 2008, 18:38

I reinstalled MAMP, (entirely) nothing in htdocs, but I am still receiving the same "Forbidden" problem even though its a completely fresh unmodified install.

I checked the Apache and MySQL logs and this is what is came up with:

MySQL

Code: Select all

080907 11:29:58  mysqld started
080907 11:29:58 [Warning] You have forced lower_case_table_names to 0 through a command-line option, even though your file system '/Applications/MAMP/db/mysql/' is case insensitive.  This means that you can corrupt a MyISAM table by accessing it with different cases. You should consider changing lower_case_table_names to 1 or 2
080907 11:29:58 [Warning] One can only use the --user switch if running as root

080907 11:29:58  InnoDB: Started; log sequence number 0 43655
080907 11:29:58 [Note] /Applications/MAMP/Library/libexec/mysqld: ready for connections.
Version: '5.0.41'  socket: '/Applications/MAMP/tmp/mysql/mysql.sock'  port: 8889  Source distribution
Apache

Code: Select all

[Sun Sep 07 11:29:58 2008] [notice] Digest: generating secret for digest authentication ...
[Sun Sep 07 11:29:58 2008] [notice] Digest: done
[Sun Sep 07 11:29:58 2008] [notice] Apache/2.0.59 (Unix) PHP/5.2.6 DAV/2 configured -- resuming normal operations
[Sun Sep 07 11:29:58 2008] [error] [client ::1] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /Applications/MAMP/bin/mamp/

This is just a guess, but could it have to do something with the error in Apache log "FollowSymLinks or SymLinksIfOwnerMatch" implying that RewriteRule is "Forbidden"

If so how would I go about changing these settings?

Also, any thoughts as to why or how this permission was set this way?
http://www.Mudutu.com
Knowledge is Power - Share it

al3
Posts: 54
Joined: Tue 26. Aug 2008, 17:20

Re: Forbidden starting page

Post by al3 » Sun 7. Sep 2008, 20:14

Was there a PHP error?

I think all is well with both Apache and MySQL. I still think this is a permissions problem.

You don't have any other installs of MySQL on the machine? You've checked to see that Personal Web Sharing is OFF in the System Prefs in Sharing folder.

Try this command:

http://localhost:8888/phpMyAdmin/

and see what error if any you get.

How about this: http://localhost:8888/MAMP/frame.php

charlesclayton
Posts: 10
Joined: Wed 3. Sep 2008, 19:32

Re: Forbidden starting page

Post by charlesclayton » Thu 11. Sep 2008, 04:59

I do not believe I have any other MySQL installs, would that be something like xampp? if so, MAMP is the only local hosting software I have used...

Web Sharing is OFF


/phpMyAdmin/ - Forbidden

/MAMP/frame.php - Forbidden

I wonder why the phpinfo would display in the test1.php file, but not /phpMyAdmin/?
Last edited by charlesclayton on Sat 13. Sep 2008, 19:24, edited 1 time in total.
http://www.Mudutu.com
Knowledge is Power - Share it

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest