MySQL/MAMP Startup problem

Report any found bug here. We are grateful for any useful clues.

Moderator: severin

Post Reply
Carolyn Ann
Posts: 1
Joined: Thu 5. Nov 2009, 19:14

MySQL/MAMP Startup problem

Post by Carolyn Ann » Thu 5. Nov 2009, 19:38

Hi! I've just downloaded and installed MAMP, yesterday, to help with a small project I'm working on.

I've installed MAMP 1.8.3 on a Mac mini running OS X 10.6.1, and mySQL is not starting. It's a brand new install, no databases have been created, no previous installs. Fresh install of OS X, too. Everything worked yesterday, but today the log file is telling me:

Code: Select all

091105 14:08:00 [Note] Plugin 'FEDERATED' is disabled.
091105 14:08:00 [Note] Plugin 'ndbcluster' is disabled.
091105 14:08:00  InnoDB: Started; log sequence number 0 44233
091105 14:08:00 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
091105 14:08:00 [ERROR] Do you already have another mysqld server running on port: 8889 ?
091105 14:08:00 [ERROR] Aborting

091105 14:08:00  InnoDB: Starting shutdown...
091105 14:08:01  InnoDB: Shutdown completed; log sequence number 0 44233
091105 14:08:01 [Warning] Forcing shutdown of 2 plugins
091105 14:08:01 [Note] /Applications/MAMP/Library/libexec/mysqld: Shutdown complete

091105 14:08:01 mysqld_safe mysqld from pid file /Applications/MAMP/tmp/mysql/mysql.pid ended
As far as I know there's nothing running on 8889! There is no other instance of mySQL on the machine. Yesterday, I quit MAMP, but didn't reboot. Just now I tried changing the mySQL port to 9001 - everything worked. I changed it back to 8889, it stopped. I rebooted, and it seems to be working, now! (On 8889.) I've stopped and started it a few times, and it seems to be happy. (Apache has been working all along.)

Is this a known bug, or just a freakish event?

Thanks!
Carolyn

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests