mysql databases loss after restart

Report any found bug here. We are grateful for any useful clues.

Moderator: severin

Post Reply
brickwalls
Posts: 2
Joined: Sun 31. Mar 2013, 15:57

mysql databases loss after restart

Post by brickwalls » Sun 31. Mar 2013, 16:27

Hi,

After I used the MAMP control panel to "Stop Servers" and "Start Servers", I lost all the changes that I made to mysql databases during the past two weeks. The databases still work, but recent changes such as adding/editing records, tables, and databases have been discarded.

I looked in the db->mysql folder. Databases that I've recently added are no longer in there. When I open the folders for a database, the MYI, MYD, and frm files said they were last modified from two weeks ago. It's as if MAMP reverted to previous version of the databases from two weeks ago.

The files in htdocs are fine. It's only the mysql databases that have been affected.

I'm running MAMP 2.1.2 and Mac OSX 10.8.2. I also set the Apache port to 80 and MySQL port to 3306.

Thanks

brickwalls
Posts: 2
Joined: Sun 31. Mar 2013, 15:57

Re: mysql databases loss after restart

Post by brickwalls » Tue 16. Apr 2013, 15:14

Found the part of the problem. The database are being stored in "~/Library/Application Support/appsolute/MAMP PRO/db/mysql/" instead of "/Applications/MAMP/db"

I downloaded MAMP Pro to test it out, but decided not keep it. For some reason the databases are being stored in the MAMP PRO folder instead of the MAMP folder.

I must have screwed up my localhost, php, mysql configuration somehow when I set up the virtual host.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest